Trouble with installing the UnlimitedHand Arduino library

Recent Topics Forums Installation & Troubleshooting Trouble with installing the UnlimitedHand Arduino library

This topic contains 16 replies, has 2 voices, and was last updated by Profile photo of H2L H2L 6 years, 5 months ago.

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #228
    Profile photo of H2L
    H2L
    Keymaster

    For those who are facing problems in installing the UnlimitedHand Arduino Library, procedures for installing libraries may differ depending on the Arduino IDE version you are using.

    Please refer to the following tutorial for details on installing libraries:
    http://dev.unlimitedhand.com/introduction/instLib4Arduino.html

    You can download the UnlimitedHand Arduino Library here:
    http://dev.unlimitedhand.com/UH4Arduino0027.zip

    UnlimitedHand Team

    • This topic was modified 6 years, 9 months ago by Profile photo of H2L H2L.
    #258
    Profile photo of jeffman
    jeffman
    Participant

    Arduino IDEを起動した後、ポートに「シリアルポート:”COM12″」などと番号で表示され、マニュアルのような表示が現れません。
    また、デバイスマネージャよりUHのポートを特定して指定したとしても、書き込み中に以下のようなエラーが表示され、書き込み完了できません。

    ==========
    Arduino:1.6.8 (Windows 7), マイコンボード:”Arduino/Genuino Uno”

    「Kalman.h」に対して複数のライブラリが見つかりました
    使用済:C:\Users\(ユーザー名)\Documents\Arduino\libraries\UH
    未使用:C:\Program Files (x86)\Arduino\libraries\UH

    最大32,256バイトのフラッシュメモリのうち、スケッチが15,710バイト(48%)を使っています。
    最大2,048バイトのRAMのうち、グローバル変数が1,315バイト(64%)を使っていて、ローカル変数で733バイト使うことができます。
    avrdude: ser_open(): can’t open device “\\.\COM14”: アクセスが拒否されました。

    マイコンボードに書き込もうとしましたが、エラーが発生しました。
    ==========

    使用OSはWindows7 HomePremium 64bitです。
    解決策などありましたらご教示願います。

    • This reply was modified 6 years, 9 months ago by Profile photo of jeffman jeffman.
    #265
    Profile photo of H2L
    H2L
    Keymaster

    English follows Japanese

    jeffmanさん,こんにちは.
    投稿ありがとうございます!

    >Arduino IDEを起動した後、ポートに「シリアルポート:”COM12″」などと番号で表示され、マニュアルのような表示が現れません。

    Windows使用時に取扱説明書と異なった画像となり申し訳ないです.
    Windows使用時の場合は,「COM(数字)」というような表示になると思います.
    ご使用のシリアルポートをご選択いただけますと幸いです.

    また,Arduinoプログラムのアプロード時は,下記の点にご注意ください.

      [USB接続の場合]
       アップロード毎にUnlimitedHandの電源ボタンを押してUnlimitedHandを再起動する

      詳細は下記ページをご覧ください
      http://dev.UnlimitedHand.com
        ->Introduction
         -> Uploading sample programs Arduino on to the device
          -> Troubleshooting: Sketch upload failure
            http://dev.unlimitedhand.com/introduction/sketch.html

      [Bluetooth接続の場合]
       Bluetooth接続がきちんとされているか確認し,うまくいかない場合は再度ペリングを実施する

    > また、デバイスマネージャよりUHのポートを特定して指定したとしても、書き込み中に以下のようなエラーが表示され、書き込み完了できません。
    > ==========
    > Arduino:1.6.8 (Windows 7), マイコンボード:”Arduino/Genuino Uno”
    >
    > 「Kalman.h」に対して複数のライブラリが見つかりました
    > 使用済:C:\Users\(ユーザー名)\Documents\Arduino\libraries\UH
    > 未使用:C:\Program Files (x86)\Arduino\libraries\UH

    Arduino IDEがどちらのライブラリを使って良いのか混乱している状態だと推測されます.
    どちらかかのUHライブラリを削除し,Arduino IDEを再起動した後,
    アップロード(書き込み)を試されてください.

    他に何か困ったことがありましたら,ご遠慮なくまた投稿されてください.

    jeffmanさんのHappy Hackingを願って!
    H2L Team

    ———————————————————————

    Hello jeffman,
    Thank you for your post and inquiries!
    > After starting up the Arduino IDE and looking in the menu for a list of available ports,
    Options like “Serial Port: COM12” are displayed, this is different from what I see on the Manual.

    Sorry for not making it clear.
    Procedures for Windows Users may differ from screenshots included in the manual.
    Windows Users should see 「COM(number)」 on their list of available ports.
    Please select the Serial Port that you are intending to use.

    As a reminder, please pay attention to the following points when you upload programs to the Arduino.

    [When running on a USB connection]

    For each upload, you must first restart the UnlimitedHand by pressing on it’s power button.

    Please visit the following pages for more details:
      http://dev.UnlimitedHand.com
        ->Introduction
         -> Uploading sample programs Arduino on to the device
          -> Troubleshooting: Sketch upload failure
            http://dev.unlimitedhand.com/introduction/sketch.html

    [When running on a Bluetooth connection]
    Make sure your Bluetooth connection is secure. If not, try repairing the device with your computer.

    > Even though I have specified in the Device Manager, the port to which the UH is connected, when I attempt to compile the code, I get the following error messages, resulting in a failure.
    ==========
    > Arduino: 1.6.8 (Windows 7), Board: “Arduino/Genuino Uno”
    >
    > Multiple libraries were found for “Kalman.h”
    > Used: C:\Users\(Username)\Documents\Arduino\libraries\UH
    > Not Used: C:\Program Files (x86)\Arduino\libraries\UH
    ==========

    I suppose that the Arduino IDE is confused about which library it should be using.
    Please try deleting one of the UH libraries, and restarting the Arduino IDE.
    After that you may try uploading your program once again.

    See if that helps, if you are still encountering difficulties, let us know with a post.

    Happy Hacking jeffman!
    H2L Team

    • This reply was modified 6 years, 9 months ago by Profile photo of H2L H2L.
    • This reply was modified 6 years, 9 months ago by Profile photo of H2L H2L.
    #295
    Profile photo of jeffman
    jeffman
    Participant

    ご回答ありがとうございます。
    遅くなりましたが、UHライブラリを削除して再度試行致しました。
    残したライブラリはこちらです。
    C:\Users\(ユーザー名)\Documents\Arduino\libraries\UH

    しかし下記のような表示が出るのみで、書き込みを完了できないようです。
    (ライブラリを複数配置する以前も同様の表示が出ておりました)
    書き込みの際はUSB接続をしたまま毎回本体を再起動してから行っています。
    なおサンプルプログラムはangle、およびVibrationMotorです。

    ====================================
    最大32,256バイトのフラッシュメモリのうち、スケッチが7,830バイト(24%)を使っています。
    最大2,048バイトのRAMのうち、グローバル変数が408バイト(19%)を使っていて、ローカル変数で1,640バイト使うことができます。
    avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
    avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
    avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
    avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
    avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
    avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
    avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
    avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
    avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
    avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00

    #296
    Profile photo of H2L
    H2L
    Keymaster

    English follows Japanese
    ————————-

    @jeffman:
    スケッチの書き込みがうまくいかない場合は, 電源ボタンを長押ししてデバイスの電源切ってデバイスを再び起動してください。
    このページの「トラブルシューティング: スケッチの書き込みに失敗する」をご確認ください。http://dev.unlimitedhand.com/ja/introduction/sketch.html 
    (日本語)

    @jeffman:
    In this case, you may try restarting the UnlimitedHand.
    Please check the tutorial “Troubleshooting: Sketch upload failure” here: http://dev.unlimitedhand.com/introduction/sketch.html
    (English)

    UnlimitedHand team

    • This reply was modified 6 years, 8 months ago by Profile photo of H2L H2L.
    • This reply was modified 6 years, 8 months ago by Profile photo of H2L H2L.
    #299
    Profile photo of jeffman
    jeffman
    Participant

    ご回答ありがとうございます。
    しかし先述の通り、再起動はすでに毎回行っておりますが、失敗します。

    #300
    Profile photo of H2L
    H2L
    Keymaster

    @jeffman
    Sorry for the trouble, would you mind confirming that you have selected “Arduino / Genuino UNO” as your board ? You can check it by selecting the options Tools -> Board on the Arduino IDE.

    If you have chosen other boards, you may receive the following error message:
    avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xac

    @jeffman
    解決できなかった申し訳ないです。
    Arduino IDEで ツール->マイコンボード を選択して使用しているボードは “Arduino / Genuino UNO”
    として設定しているかどうかを確認していただけませんか。

    違いのボードに設定すれば下記のエラーメッセージ出るはずです:
    avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xac

    UnlimitedHand team

    #301
    Profile photo of jeffman
    jeffman
    Participant

    はい、“Arduino / Genuino UNO”となっています。

    #302
    Profile photo of H2L
    H2L
    Keymaster

    English follows Japanese
    ????????-

    @jeffman
    Thank you for your reply,

    I would need information about your PC and UnlimitedHand to troubleshoot further,
    would you mind answering the following questions ?

    1. Was your UnlimitedHand powered on when you upload the Arduino code?
    ※ UnlimitedHand should be turned on (Green LED visible) when you upload Arduino codes.

    2. Was your PC connected to the device through a USB micro B-A when you uploaded the code?
    ※ Please use a USB connection so that we can verify if it is an hardware issue.

    We hope we can solve this problem soon!

    @jeffman
    ご返信ありがとうございます。
    jeffmanさんのデバイスとパソコンの状態をもっと理解するように下記の質問を答えていただけませんか。

    1. ArduinoプログラムをアップロードするときUnlimitedHandの電源が入れていますか。
    ※ Arduinoプログラムをアップロードする前デバイスの電源はON(緑LEDが光っている)にしてください。

    2. ArduinoプログラムをアップロードするときパソコンはデバイスとUSB micro B-Aケーブルで連結していますか。
    ※ 今回の検証のためUSBで連結してください。

    お手数をお掛けして申し訳ありません。

    UnlimitedHand team

    #303
    Profile photo of jeffman
    jeffman
    Participant

    1.はい、ランプは緑色に点灯しています。
    “Unlimitenhand”ロゴのすぐ真上にあるランプですね。
    もう片方は消灯しています。

    2.はい、付属の白いUSB micro B-Aケーブルでの接続です。
    念のためBlueTooth接続も試しましたが、書き込みの際は常にUSBを使っています。

    また、気になる点が1つあります。
    初回起動からそうなのですが、電源をONにすると本体が小刻みに振動しています。
    これは正常でしょうか。

    #304
    Profile photo of H2L
    H2L
    Keymaster

    English follows Japanese
    ————————

    @jeffman
    ご返信ありがとうございます。jeffmanさんのArduino開発環境はバージョン1.6.8(Windows 7)のことを分かりました。WindowsユーザーがArduinoIDEを使用する時前に、FTDIドライバを更新しないと書き込めない状況もあるので、下記のリンクでjeffmanさんのプロセサ構築(32-bit,64-bit)に従って、最新版のFTDIドライバーをインストールしていただけませんか。

    FTDIドライバーダウンロードサイト:
    http://www.ftdichip.com/Drivers/VCP.htm

    ドライバーをインストールする手順は下記のサイトに記載していますので、ご参考までに御覧ください(日本語):
    http://www3.big.or.jp/~schaft/hardware/tips/FTDI_driver/page001.html

    お手数をお掛けして申し訳ありません。
    UnlimitedHand team

    ———————

    @jeffman
    Thank you for your reply, from the posts above it seems that you are using Arduino IDE version 1.6.8 on Windows 7. For Windows users, there has been cases where compilation have failed due to an outdated FTDI driver. By default, Windows does not have FTDI drivers installed. Please access the following site, download and install the latest FTDI driver that is compatible with your processor’s architecture (32 or 64 bit).

    Download link for FTDI Drivers:
    http://www.ftdichip.com/Drivers/VCP.htm

    Access the following site for detials on how to install the driver (English):
    https://learn.sparkfun.com/tutorials/how-to-install-ftdi-drivers/windows—quick-and-easy

    Sorry for the trouble,
    UnlimitedHand team

    #305
    Profile photo of jeffman
    jeffman
    Participant

    ご教示頂いた通り、ドライバインストールによって無事書き込みに成功しました。
    ご対応ありがとうございました。

    #306
    Profile photo of H2L
    H2L
    Keymaster

    @jeffman 
    書き込めるはよかったです。
    投稿ありがとうございます!

    @jeffman
    Im glad that it has finally worked out.
    Thanks for raising the problem!

    #317
    Profile photo of jeffman
    jeffman
    Participant

    お久しぶりです。

    Windows7にてBluetooth接続をした状態でArduino上で動作確認をしようとしたのですが、「ペアリングコード(PIN)が誤っている」とメッセージが表示されてしまい、確認ができません。
    なおコードはこちらのものをそのまま入力しています。
    http://dev.unlimitedhand.com/ja/introduction/bluetooth.html

    どのように入力すればよいか、ご教示願います。

    #320
    Profile photo of H2L
    H2L
    Keymaster

    @jeffman
    投稿ありがとうございます。
    以下のステップの通りBluetoothを再接続してください。
    1. デバイスと接続しているUSBケーブルを外してください。
    2. デバイスとパソコンのBluetooth接続を解除してください。
    3. デバイスを再起動してください。
    4. [デバイスとプリンター] → [デバイスの追加] を選び、デバイスを選んで、[次へ] を選びます。

    ぜひ試されてください。よろしくお願い致します。
    UnlimitedHand team.

Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic.